There can be several reasons why an image in an Advanced Custom Fields (ACF) Pro Repeater field is not showing. Here are a few things you can check to troubleshoot the issue:

  1. Make sure the image is properly uploaded to the Media Library and the URL is correct. You can check the image URL by inspecting the element in the front-end or by going to the Media Library in the WordPress admin.
  2. Make sure the ACF Pro Repeater field is properly configured and connected to the image field. Check the field name and make sure it matches the name of the field in the repeater.
  3. Make sure the correct image size is being called in your code. If the image size is not specified, the default image size will be used, which may not be the correct size.
  4. Make sure the correct field is selected in the repeater and the right template is being used to display the image.
  5. Check the server and the browser, the image maybe blocked by the server or the browser due to security reasons, or the image’s format or size.
  6. Try to use a different browser, it could be a browser compatibility issue.
  7. Make sure your PHP version is up to date, and that the latest version of ACF Pro is installed, it could be a compatibility issue.
  8. check the server and the browser, the image maybe blocked by the server or the browser due to security reasons, or the image’s format or size.

It’s important to note that some of these steps might require some technical knowledge, if you are not familiar with them, you may want to consider hiring a developer or a professional service to fix the issue.

(Visited 88 times, 1 visits today)
Was this article helpful?
YesNo
Close Search Window